Что такое native vlan

Что такое native vlan

Материал из Xgu.ru

Native VLAN — это понятие в стандарте 802.1Q, которое обозначает VLAN на коммутаторе, где все кадры идут без тэга, т.е. трафик передается нетегированным. По умолчанию это VLAN 1.

В некоторых моделях коммутаторов, например, cisco, это можно изменить, указав другой VLAN как native.

Если коммутатор получает нетегированные кадры на транковом порту, он автоматически причисляет их к Native VLAN. И точно так же кадры, генерируемые с не распределенных портов, при попадании в транк-порт причисляются к Native VLAN.

Трафик, который принадлежит другим VLANам, тегируется с указанием соответствующего VLAN ID внутри тега.

Содержание

[править] Примеры настройки Native VLAN

[править] Коммутаторы Cisco

Настройка VLAN 5 как native:

Теперь весь трафик принадлежащий VLAN’у 5 будет передаваться через транковый интерфейс нетегированным, а весь пришедший на транковый интерфейс нетегированный трафик будет промаркирован как принадлежащий VLAN’у 5 (по умолчанию VLAN 1).

Проверить какой VLAN настроен как Native:

Из соображений безопасности (например, для защиты от VLAN Hopping) рекомендуется в транке выполнять тегирование даже для native VLAN. Включить тегирование фреймов для native VLAN глобально можно с помощью команды vlan dot1q tag native, просмотреть текущий статус тегирования можно используя команду show vlan dot1q tag native.

[править] Коммутаторы HP (ProCurve)

Для коммутаторов HP нет явной команды, которая настраивает Native VLAN. Для того чтобы настроить Native VLAN на этих коммутаторах, нужно просто указать, что в нужном VLAN определенный порт будет нетегированный:

Автор Гапон Анатолий создана 15. Jan, 2011 категория Switching, Vlan

Настройка native vlan полезная в случае когда необходима связь между двумя vlans находящимися на разных коммутаторах . Для того чтобы коммутаторы правильно взаимодействовали необходимо порты , соединяющие собой разные коммутаторы настроить в режиме trunk. Trunk – называют режим работы порта, который обеспечивает взаимодействие vlans на разных коммутаторах.
Cisco vlan предлагают стандарт 802.1 q, этот стандарт предусматривает использование специальных заголовков vlan в пакете.
Что касается конкретной задачи, то для trunk-порта можно настроить native vlan.
Транковый порт с native vlan работает следующим образом :
1.Если из коммутатора через trunk-порт выходит кадр из native vlan – по транку он идет без тега заголовка (тега) vlan.
2.Если по транку на порт приходит кадр без заголовка vlan – он отдается в native vlan , который настроенный для порта. К ему приписывается тег native vlan.
Другими словами при прохождении транка кадр лишается заголовков , и тем самым заставляет принимающий коммутатор пересылать кадр в vlan , настроенные на нем.

И так переходим к конфигурации.
Для этого нам понадобятся два коммутатора и два хоста , по одному с каждой стороны транка.
Для начала добавим порты , к которым подключены компьютеры в vlans:

Читайте также:  Как настроить микрофон и колонки

SW0#en SW0#conf t SW0(config)#interface fastEthernet 0/1 SW0(config-if)#switchport access vlan 2

% Access VLAN does not exist. Creating vlan 2
И также на другом коммутаторе:

SW1#en SW1#conf t SW1(config)#interface fastEthernet 0/1 SW1(config-if)#switchport access vlan 50

% Access VLAN does not exist. Creating vlan 50
Обратите внимание на то что если не создавать vlan предварительно, то при добавлении в не существующий vlan, он создается автоматически, и система информирует об этом.
Посмотреть базу vlan можно , с помощью команды :


Аналогичный вывод и на SW1 :

Теперь настраиваем trunk и на нем native vlan , номер native vlan должен соответствующим тому vlan, с которым мы хотим настроить связь.
SW0

SW0(config)#interface fastEthernet 0/2 SW0(config-if)#switchport mode trunk SW0(config-if)#switchport trunk native 2

SW1

SW1(config)#interface fastEthernet 0/2 SW1(config-if)#switchport mode trunk SW1(config-if)#switchport trunk native vlan 50

Посмотреть какие порты находятся в режиме trunk можно командой

show interfaces trunk


Настроим ip-address на ноутбуках, подключенных в vlan:
laptop0 – 10.0.0.1
laptop1 – 10.0.0.2

Проверим соединение командой ping на ноутбуке :


Теперь когда мы убедились в работоспособности мы добавим на SW0 еще один vlan, для того чтобы точно быть уверенными что vlan , не настроенный на native не будет взаимодействовать с другими vlan.

SW0(config)#interface fastEthernet 0/3 SW0(config-if)#switchport access vlan 99

% Access VLAN does not exist. Creating vlan 99
Назначим ip-address :
laptop2 – 10.0.0.3
Проверяем командой ping что хост с vlan 99 не может ни с кем взаимодействовать:


На этом настройка и проверка заканчивается .
Скачать пример можно в низу статьи, спасибо за внимание!

или Just Another CCNA Blog

суббота, 14 мая 2011 г.

Маленькое дополнение про Native VLAN.

Так как кадры Native VLAN обязаны проходить по транк-линкам без тегов, появление в транк-линке кадра с тегом номер которого совпадает с номером Native VLAN является не допустимым, и коммутатор получив такой кадр его уничтожает.
Скачать: pkt-файл

Читайте также:  Как правильно подключить колонки к сабвуферу

PS в pkt-файле есть небольшое изменение. Порты коммутаторов fa 0/2 переведены в режим trunk. Результат точно такой же, кадры идут без тега и дублируются на порты распределенные в первый влан (т.к. он же native) и наоборот.
PPS если задать на коммутаторах разные Native vlan, то можно получить ситуацию с отбрасыванием кадров при совпадении тега с номером native vlan.

18 комментариев:

Тогда не должен пройти пинг от pc5 к pc6(транковый vlan совпадет с тегом vlan1), и судя по всему 1 коммутатор должен такой пакет отбросить.Я правильно понимаю?

Пройдёт элементарно этот пинг.
А что значит транковый vlan? Транк тегирует кадр, указывая там принадлежность кадра к определённому vlan, если это кадр native vlan, то транк с ним ничего не делает.

пинг будет проходить потому, что в данной лабе native vlan на коммутаторах совпадает.

тоесть Native vlan совпадает с vlan1(судя по написаному вами выше "Так как кадры Native VLAN обязаны проходить по транк-линкам без тегов, появление в транк-линке кадра с тегом номер которого совпадает с номером Native VLAN является не допустимым, и коммутатор получив такой кадр его уничтожает.")
Это уточнение к первому вопросу,хочу разобраться.Спасибо.

native vlan совпадает с vlan1 по умолчанию, но вы при желании можете это изменить.
Да, он действительно его уничтожит, потому как это будет означать, что на коммутаторах не совпадает native vlan, эта проблема довольно просто исправляется, на одном из коммутаторов просто меняете native vlan на такой же самый (как и на других устройствах домена).

Если в транк с native vlan 10 попадет тегированный траффик(vlan 10) транк просто снимет этот тэг.

да на входе в транк свич снимет тег с такого кадра.
но если каким то чудом в самом транке появится тегированный кадр и прийдет на порт коммутатора он должен его отбросить.

Читайте также:  Что можно дорисовать из ромба

Я бы немного уточнил последнее предложение, добавив некоторые слова для более лучшего восприятия. Вот как это бы выглядело: "Так как кадры ПРИНАДЛЕЖАЩИЕ Native VLAN обязаны проходить по транк-линкам без тегов, появление в транк-линке кадра с тегом номер которого совпадает с номером Native VLAN КОММУТАТОРА, КОТОРЫЙ ПОЛУЧАЕТ ЭТОТ КАДР, является не допустимым, и коммутатор, получив такой кадр, его уничтожает."

насчет того, отбрасывается ли такой кадр это еще под вопросом. все никак не проверю на оборудовании

Смоделировал схему в PT по которой коммутатор получив из транка номер Native VLAN’а должен удалять такой VLAN. Ну. Ни хрена. Не удаляет. Коммутатору не фильтрует номера VLAN’ов в транке, если они совпадают с Native VLAN’ом. Он их пропускает через себя без ограничений.
Если интересно, попробуйте сами:
ROUTER1:
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.0

ROUTER2:
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.10.2 255.255.255.0
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.20.2 255.255.255.0

SW1, SW2:
interface FastEthernet0/1
switchport trunk native vlan 10
switchport mode trunk
!
interface FastEthernet0/2
switchport trunk native vlan 10
switchport mode trunk

Схема: ROUTER1 SW1 SW2 ROUTER2

да я в курсе. последнюю неделю как раз этот вопрос разбирал )))
видимо все таки в курсе ошибка или неверная формулировка.

Ссылка на основную публикацию
Что делать если плохо работает отпечаток пальца
Владельцы современных смартфонов на платформе Android нередко сталкиваются с тем, что сканер отпечатков пальцев реагирует недостаточно быстро и точно. Зачастую...
Хайскрин пауэр айс эво
Вас интересуют характеристики Highscreen Power Ice Evo (Хайскрин Повер Ис Эво)? Мы собрали всю важную информацию, чтобы помочь определиться с...
Халявные страницы в вк логины и пароли
Please complete the security check to access youhack.ru Why do I have to complete a CAPTCHA? Completing the CAPTCHA proves...
Что делать если пропал звук в наушниках
Всё о Интернете, сетях, компьютерах, Windows, iOS и Android Нет звука в наушниках на телефоне — что делать?! А Вы...
Adblock detector